go minimal
그는 물었다 12년 전
2

Os X 에서 작동하지 sqlite3-ruby-1.2.2 이유는 무엇입니까?

제가 운영하는

  • OS X 10.5,
  • 1.8.6, 루비
  • 레일 2.1,
  • sqlite3 루비 1.2.2

내가 할 때 다음과 같은 오류가 내려받습니다 거둘 수 있는 앱을 접속됨 찾기 '는 MySQL db:' 마이그레이션합니다 협력하였습니다.

&gt. 수입 중단! no such file 로드하기에 sqlite3/database

답변 2 개

방금 자미 릴리즈됨 1.2.4 에 있는 역사 및 버그 수정 및 이후 버전 1.2.3 주석문입니다 해당하는 것이다. 제가 한 다음, OS X 10.5 대로 신속하게 테스트하려면 협력하였습니다 상자를 루비 1.8.6:

sudo gem install sqlite3-ruby

(검증되었습니다 버전 번호를 1.2.4)

rails test

('다타바스그림리 sqlite3 사용되는 기본' 을 (를)

cd test
./script/generate model Person name:string
rake db:migrate

좋았소 실행했음 오류가 있었을 때 필요한 것은 '들어온넘 sqlite3 마이그레이션과 전에 # 39 위를 영업사원이에요 도왔으매 마치 they&, ve 문제가 해결되었습니다.

[강] # 39 there& looks like a, s (http://rubyforge.org/tracker/index.php) =, =, =, = 1043년 아티드 254&amp group_id? func detail&amp a-id 20533&amp) 와 1.2.2. 그냥 위해 롤백합니다 1.2.1 호스트당: &gt. v = 1.2.1 컴팩트형 sqlite3 루비 설치

그리고 그 문제가 해결됩니다.