Jonas
그는 물었다 8년 전
86

린텔리 IDEA 와 어떻게 실행합니까 Mac OS X 에서 JDK 7?

내가 사용하는 Mac OS X 10.8.2 사용하고, JDK 7. 린텔리 IDEA, 이젠 다운로드했습니다 최신 버전의 11. 하지만, JDK 6 없이 시작해 t # 39 doesn& 것으로 보인다. 유지됩니까 해결하십시오?

린텔리 IDEA 와 Mac OS X 에서 JDK 7 실행하십시오 어떻게 해야 합니까?

Mrugen Deshmukh
그는 6년 전 댓글을 달았습니다
3

저도 비슷한 문제를 안고 설치할 때, 이 값을 에서 JDK 8 할 수 있는 애플리케이션을 1.6 1.8 제프 베르시온 변경하여 해결하십시오 " / / IntelliJ IDEA 13.app/Contents/Info.plist".

답변 5 개

  • UPDATE:*

Jdk 의 12 아이디어를 실행할 때 1.7 (변경 후 '를' '에서' '제프 베르시온 1.7* 린포드프리스트') ',' LANG = en_US.UTF-8 환경에서 볼 수 있는지 관련 jave 문제:

[참조할 스레드할] (http://devnet.jetbrains.com/message/5472745 # 5472745) 를 디버깅하지 launcher 문제.

또한 Mac 의 GUI 응용 프로그램 환경 없는 점을 유념하십시오 desktopplatforms 털미널 액세스할 수 있습니다. # 39 에서 정의된 you& 경우, ve, 다른 응용 프로그램을 실행할 때 일부 환경 변수를 사용할 수 있는 좋은 털미널 아닌 이러한 변수를 터미널 보이지 않습니다. A 는 응용 프로그램을 시작하는 이 문제를 해결하기 위해 직접 아이디어를 위한 터미널, 다음 명령을 사용할 수 있습니다.

open -a /Applications/IntelliJ\ IDEA\ 12.app/

지금 같은 몇 가지 알려진 문제에 대한 지원 가능한 레티나 지원, Mac, JDK 1.7 누각되었습니다 깜박거림 [일부 api 가 구현되지 않음] (http://youtrack.jetbrains.com/issue/IDEA-93710). # 39 의 아이디어를 실행할 수 있는 가장 좋은 방법은 JDK 1.6 it& 매우 권장됨 Mac 의 경험하십시오 doesn& # 39 를 JDK 1.7 대상으로 t 정지점을 있어, 구축 및 실행을 위한 프로젝트에 있습니다.

-

IntelliJ IDEA 11 JDK 1.7 Mac 의 실행 사용할 수 없습니다. 이 순간 JDK 1.6 버전을 실행할 수 있도록 11 살 생각은 설치되어 있어야 합니다.

drvdijk
Jonas
그는 8년 전 댓글을 달았습니다
0

뉴스를 볼 때 이 모든 것이 이제 12 는 릴리즈됨? 모든 해결 방법?

CrazyCoder
그는 8년 전 댓글을 달았습니다
0

내 생각은 작동하잖아 12 http://schmidt. devlib. [이 게시물로의] (http://devnet.jetbrains.net/message/5472745 # 5472745).

Jonas
그는 8년 전 댓글을 달았습니다
4

39, 해당 doesn& 가져다줄래요 빗나갔다. '시작' 과 '아이디어' 를 할 때 내가 제프 베르시온 변경하십시오 1.7* 12, 나는 계속 메시지는 데릭쉐퍼드와 JRE 6.

CrazyCoder
그는 8년 전 댓글을 달았습니다
0

잘 모르는 문제가 있지만 말해둘꼐요 작동됨 for me, in your 경우 다른 사용자가.

9ee1
그는 8년 전 댓글을 달았습니다
8

이는 작동안함 가져다줄래요 중 하나. 신선한 아이디어를 실행하는 마운틴 라이언 설치, 10, 12 여전히 업데이트하십시오 jave 7 days for Java 6. Java - 버전인 '실행' 에서 털미널 작동합니다. 생각을?

CrazyCoder
그는 8년 전 댓글을 달았습니다
0

네, 아이디어 @agarhy 보지 못할 털미널 환경 때문에 [Mac 관련 사항을] (http://apple.stackexchange.com/q/57385/17551) 에서 이 제품을 실행하십시오 털미널: open - /Applications/IntelliJ\ IDEA\ 12.app/ '는'

Brice
그는 8년 전 댓글을 달았습니다
1

그러나 JDK7 사용할 수 있는 프로그램을 사용하여 망막 소유자, 참고 속임수, 그리고 렌더링됩니다 비사양 레티나 해결안에서는 산하이어솔루션카파블레 won& # 39, 빗나갔다. Oracle 은 JDK 8, let& 망막 지원하기 위해 추가 # 39 의 2013년 s hope, JDK8 랑하니 릴리즈됨 셉트 됩니다. 지켜보리니 bug_id = 8000629 http://lists.apple.com/archives/java-dev/2012/Oct/msg00144.html http://bugs.sun.com/bugdatabase/view_bug.do?

Isaac
그는 7년 전 댓글을 달았습니다
0

나도, 심지어 열어 털미널 에서 작동하지 않습니다. 하지만 나는 12 CE, 문제가 될 되겠습니까?

CrazyCoder
그는 7년 전 댓글을 달았습니다
0

빌드 번호는 @is7aq 생각은 무엇입니까? 혹시 린포드프리스트 수정하십시오 파일? 첨부 파일을 수정 후 수 있습니까? Jdk 1.7 가리키는 JAVA_HOME 정의된 있습니까? 예를 들어, 문의처를 지원 팀에 도움이 필요한 경우 우리는 이 문제를 어떻게 로그 안내선 디버그로 launcher 표시되는 JDK 버전이 아닌 특정 저회가 왜 다른 선정됐다. 답을 다운보팅 도움이 되지는 않습니다.

neu242
그는 7년 전 댓글을 달았습니다
2

망막 7u40 자바 가상 머신 (jvm) 에 대한 문제가 수정되었습니다. https://stackoverflow.com/a/17029720/13365

Johann
그는 7년 전 댓글을 달았습니다
0

, 그래도 지침에 따라 한 @crazycoder &quot T&quot 내려받습니다 동일한 오류. 내가 읽은 당신이 말한 것은 아무 것도 본 적 없이 스레드할 제트브레인스 최근 또는 관련. Intellij idea 는 ',' 내 린텔리 구체화하십시오 구축하십시오 12.1.6 IU-129.1359 구축하십시오 1.7.0_45-b18 구축하십시오 jave 보고서 ',', 그리고 I& # 39 m, OS X 의 10.9.

tony19
그는 6년 전 댓글을 달았습니다
2

프리스트 편집하기를 사퇴 후, smartupdate 앱 번들에는 잔소리를 시작할 때 미리 확인 및 띄엄필렛 멈춥니다. [코드 사인오프하는 cert) 만들기 (https://developer.apple.com/library/mac/documentation/security/conceptual/CodeSigningGuide/Procedures/Procedures.html) 및 'sudo - verbose -, - 예증으로 &quot 실행하십시오 코즈니 인력용 &lt, cert 일반적인 name&gt "; /Applications/WebStorm.app/ '

akauppi
그는 6년 전 댓글을 달았습니다
1

나를 위해, 맥 os X 로 변경, JDK 8u5 제프 베르시온 1.8* 협력했습니다 10.9.3 13.1.3 IntelliJ IDEA,

CrazyCoder
그는 6년 전 댓글을 달았습니다
0

이 점은 @willjthomas 조금 생각을 읽을 수 있는 특수 코드 버전 비활용 최신값 털미널 환경 시작.

Jonas
그는 6년 전 댓글을 달았습니다
0

@CrazyCoder: 왜 우리는 여전히 편집하십시오 린포드프리스트 에서 하는 '지금' 린텔리 14? 스빌 이 문제를 해결 할 수 없다?

Riccardo Cossu
그는 5년 전 댓글을 달았습니다
0

zk 플러그인에는 제대로 작동하지 않기 위한 아이디어를 실행하는 유념하십시오 java 와 함께 6.

Mac OSX 요세미티 / 엘 캐피탄 업데이트

내가 가진 최고의 설치되었고, 이와 같은 메시지를 받았다고 15 린텔리. 난 또 jave 1.7-1.8 설치되어 있다.

내가 이 터미널에서 다음 단계를 통해 해결했다.

$ cd /Applications/IntelliJ\ IDEA\ 14.app/Contents

'편집' 린포드프리스트 파일이므로 변경일 이 비트:

<key>JVMVersion</key>
<string>1.6*</string>

다음과 같이 사용된다.

<key>JVMVersion</key>
<string>1.8*</string>

출시 후, 모든 게 중요.

ddavison
digit plumber
그는 6년 전 댓글을 달았습니다
1

마치 작동됨 매력. 감사합니다!

jdsumsion
그는 6년 전 댓글을 달았습니다
1

또한 13 수행됨 린텔리 Ultimate.

Sergio Tulentsev
그는 6년 전 댓글을 달았습니다
4

모든 게 golden&quot "; - 그래 이제 것을 제외하면 글꼴에서처럼 여바바 밀어버릴꺼에요 사악함이라 및 눈 부서지는

Freddy
그는 5년 전 댓글을 달았습니다
0

린텔리 임기 내 it for me, Mac OSX 10.10 및 Java 7 또는 8 로 14 와 나에게 나쁜 공기를 최대 20 개의 재부팅되기 부팅하도록 OSX 다시 하드 리셋이나 필요한 것. Solution for me: 자바 버전을 모두 제거합니다. Apple 의 설치만 jave 1.6 (http://support.apple.com/kb/DL1572). 7/8 / JDK 설치 및 구성 및 프로젝트 구조 안에서 필요한 SDK 린텔리 필요에 따라. 더 이상 볼 수 없는 것은 정말 열심히 나를 위해 시간을 내 Mac Air 부트하지. 린텔리 IDEA for Oracle 에서 이 문제를 더 홍보해야 한다, 구글, Mac 용) 와 안드로이드 사용자! 시간 cost for me: 4 시간.

Carlos Bribiescas
그는 5년 전 댓글을 달았습니다
0

이전에 내가 갖고 있는 문제는 내 이런게야 # 39, t let me for my Mac wouldn& 내 키홀더 팀시 및 응용 프로그램을 사용할 수 있기 때문에 내가 svn 비밀번호란 수정되었음 폴더에서는. 이 문제를 다운로드되었는지 보관합니까 팝업됩니다 지금?

ddavison
그는 5년 전 댓글을 달았습니다
0

난 아무 생각이 없다 "고 했는데, 이 문제를 @carlosbribiescas i& # 39.

jimoleary
그는 5년 전 댓글을 달았습니다
0

이 협력했습니다 for me. # 39, & # 39 는 구체적인 오류 메시지가 &quot tools.jar&;; classpath 에 생각이 없는 것 같다. Java_home 가리키는 것이 아니라, JDK JRE&quot 확인하십시오.

Frank
그는 5년 전 댓글을 달았습니다
0

애플 I set 이 JRE 설치 후, 이 정보는 아아아안녀어엉 나를 수 있으며, tip 은 제프 베르시온 1.7* &quot 린텔리 JVM&quot 유효함 찾을 수 없습니다. . 하지만 사실 저는 1.7 포인트 (jdk 1.7-1.8 과 java_home 버전. 모든 solution for this?

Riccardo Cossu
그는 5년 전 댓글을 달았습니다
1

mac Os x 에서 java 를 이용한 방법은 아닐 권장됨 실행하십시오 옳은 일을 하는 것이 8 참조하십시오. https://youtrack.jetbrains.com/issue/IDEA-126847

린텔리 13, 맥 os X 10.9, 내가 할 수 있는 프리스트 를 묻지 않고 그냥 변경하십시오 1.7* 및 작동하잖아 jave 7 에서 Java 6 설치.

Steve K
그는 7년 전 댓글을 달았습니다
1

그냥 OS X 에서 JDK 1.7.0_45 및 린텔리 13.0.2 10.8.5 oralce 함께 했던 이 글꼴은 여바바 안좋게요 지금은 JRE 6 선호하는 편입니다!

jaredjacobs
그는 7년 전 댓글을 달았습니다
2

그냥 이 OS X 에서 JDK 1.7.0_51 및 린텔리 13.0.2 과 10.9.1 한 멋진 디자인을 글꼴은 의 레티나 디스플레이. 그들은 함께 JDK 1.7.0_25 흐리게 보였다. Oracle 고정식입니다 1.7.0_40 이 사안에 대해 누군가 말했다. 최신 있습니다. http://www.oracle.com/technetwork/java/javase/downloads/jdk7-downloads-1880260.html

Spyder
그는 6년 전 댓글을 달았습니다
0

안타깝게도 이 방화벽, 바람을 프리스트 때마다 프롬프트합니다 린텔리 로드되는지:

13581526 https://stackoverflow.com/questions/13578062/how-to-increase-ide-memory-limit-in-intellij-idea-on-mac/13581526

이는 가치는 얼마일까요? 이 모든 메시지가 설치했거나 JRE6 린텔리 로드형? )

tony19
그는 6년 전 댓글을 달았습니다
2

이후 변경한 후 사퇴 의사를 @spyder app 서명입니다 변경으로부터 프리스트 앱 번들에는 잔소리를 프롬프트합니다 막을 수 있습니다. Cert 는 코드 사인오프하는 웹스톰, 내가 만든 대한 내 로그인시키는 키홀더 (https://developer.apple.com/library/mac/documentation/security/conceptual/CodeSigningGuide/Procedures/Procedures.html) 를 선택하고, cert name&gt &lt &quot - verbose - - 'sudo 코즈니 실행했음 인력용 예중이 ";; /Applications/Webstorm.app/ '

Spyder
그는 6년 전 댓글을 달았습니다
0

아 물론, 내가 왜 t # 39 didn& 생각할:)

Spyder
그는 6년 전 댓글을 달았습니다
9

작업 중인 애디슨에게, 1.8* jave 8.

denmojo
그는 6년 전 댓글을 달았습니다
0

변경일 린포드프리스트 1.8* 수 있는 요세미티 Beta 및 작동합니다.

Spyder
그는 6년 전 댓글을 달았습니다
0

린텔리 14 도 사용할 수 있는 것으로 보인다.)

오류 메시지는 여전히 사람들을 위한 가져오는 jave 6 설치해야 합니다. 다음과 같은 두 가지 문제

  1. Mac OS 를 설치할 수 있도록 하는 자바 애플리케이션 린포드프리스트 파일에 map_layer 섹선에서 때마다 1.6
  2. 또한 java jdk 1.6 심하게 린텔리 launcher 함께 있다.

All you need is:

  1. 셸 스크립트를 실행 (콘텐츠 / MacOS / 아이디어) 를 통해 기존 대체하십시오 명시성 jave 호출 (매개변수 및 classpath 에서 Info.plist& 취할 수 있는 # 39 의 jave 섹션).
  2. &Quot 제거하시겠습니까 Java"; 섹선에서 린포드프리스트 에서

https://github.com/wonder-mice/mac-java-launcher 자동화합니다 사용할 수 있는 것, 또는 사용할 수 있습니다 (i believe 로 아니라 린텔리.

Wim Deblauwe
그는 6년 전 댓글을 달았습니다
0

'13' 을 (를) 린텔리 mac 자바 실행기 노력했다고 하지만 작동하지 않습니다. Attaboy 'Error: 자바 애플리케이션 '아닙니다.

wonder.mice
그는 6년 전 댓글을 달았습니다
1

빔 데브라우에, 새로운 버전의 mac 자바 실행기 수정해야 합니다.

다른 매우 우수한 솔루션을 제안했다고 확장하지만 수동으로 해야 할 vi 편집기에는 상술합니다. 대신 이 명령을 실행할 수 있습니다 너회의 통해 Mac 털미널 되므로 상황보고해 움직일만 합니다.

find /Applications/IntelliJ*/*Contents/*Info.plist  -exec sed -i -e 's/string>1.6/string>1.7/' {} \;

enter 이미지 여기에 설명을!

몇 옵션임 팁:

  1. Jdk 1.8 설치되어 있는 경우 그 위의 함장님이요 1.8 1.7 바꾸면 됩니다
  2. 언제나 그렇듯이 복사본인 폴더란 만일의 사태에 대비해 스케쳐내 린포드프리스트 에서 만들기 위해 여러 가지 이유로 비교 결과 또는 되돌릴 또는 다른.
  3. 변경하십시오 실행하십시오 확인하기 위해 열렸다.
  • 'string&gt 1.7&quot 그렙 ";; Applications/IntelliJ/Contents/Info.plis * '
Sergey Lysenko
그는 5년 전 댓글을 달았습니다
1

고마워, 이것이 가장 간단한 방법은 모든 app 의 인력용 제트브레인스 실행하십시오 jave 8